fbpx Edge Gateway IPSec VPN | WaveCom

Edge Gateway IPSec VPN

 

0.

IPSec VPN

 Kui soovite VMware Cloud serveritele ja võrgule ligipääsu võimaldada ainult enda kodust või kontorist ja sulgeda selle ülejäänud maailmale, sobib selleks ideaalselt IPSec VPN lahendus. See tähendab, et võrguliiklus Teie kontori ja Cloudi vahel käib üle turvalisse, krüpteeritud tunneli.

VPN abil võib näiteks ka ühendada kaks geograafiliselt eri punktis asuvat võrku ühtseks tervikuks. IPSec äppid on olemas ka Android ja iOS seadmetele.

ipsec.png

 

1.

Avage enda Cloud keskkond ning liikuge enda Edge Gatewayde juurde, seejärel vajutage enda Edge Gateway peale.

Esimene samm

  • Valige Services alt "IPSec VPN" ning vajutage "New" peale.

Teine samm

 

 

2.

Teile avaneb IPsec tunneli loomise aken. Avalehel on võimalik kontrollida turvaprofiili kasutatavaid parameetreid. Selle info põhjal saate seadistada enda välist võrguseadet.

3

Järgmisel lehel saate sisestada enda jagatud võtme IPsec tunneli jaoks.

ipsec_pass

Endpoint Configuration lehel tuleb tähelepanelik olla.

Local Endpoint all on mõeldud Teie pilve parameetreid, IP aadressi alla läheb üks Teie Edge'i väline IP aadress. Networks alla läheb Teie soovitud kohtvõrk CIDR kujul.
Remote Endpoint all on mõeldud Teie välist võrguseadet ja selle kohtvõrku (nt: kontori ruuter). IP aadress vastab Teie välisvõrguseadme IP aadressile ning "Networks" alla läheb taas Teie soovitud kohtvõrk, samuti CIDR kujul.

5

3.

Vajutage Next peale ning kontrollige taas kõik seadistus üle ning vajutage "Finish" peale.

Kui kõik on korrektselt seadistatud, lisab Edge gateway ise kõik vajalikud tulemüüri reeglid ja paneb tunneli püsti.

 

4.1.

Kui kasutate Edge Gateway'd koos kontori MikroTikiga. Tehke lahti MikroTiki konsool ja sisestage järgmised käsud koos parandustega vastavalt enda võrgule.

  • /ip ipsec profile add dh-group=modp2048 dpd-interval=1m enc-algorithm=aes-128 hash-algorithm=sha256 name=VPN_Profile prf-algorithm=sha256
  • /ip ipsec peer add address=185.246.185.13/32 exchange-mode=ike2 local-address=80.79.113.50 name=VPN_Peer profile=VPN_Profile
  • /ip ipsec proposal add auth-algorithms=sha256 enc-algorithms=aes-128-gcm lifetime=1h name=VPN_Cloud pfs-group=modp2048
  • /ip firewall filter add chain=forward dst-address=192.168.2.0/24 src-address=10.10.10.0/24
  • /ip firewall filter add chain=forward dst-address=10.10.10.0/24 src-address=192.168.2.0/24
  • /ip firewall nat add chain=srcnat dst-address=192.168.2.0/24 src-address=10.10.10.0/24
  • /ip firewall nat add chain=srcnat dst-address=10.10.10.0/24 src-address=192.168.2.0/24
  • /ip ipsec identity add notrack-chain=prerouting peer=VPN_Peer secret=#TunneliSalasõna#
  • /ip ipsec policy add dst-address=192.168.2.0/24 level=unique peer=VPN_Peer proposal=VPN_Cloud src-address=10.10.10.0/24 tunnel=yes

 

NB! Tulemüüri reegli mitte toimimisel, palun kontrollige tulemüüri reeglite järjekorda. Näiteks: NAT tabelis srcnat masquerade reegel peaks olema nende reeglite all.

4.2.

Juhul kui soovite ühendada Cloude omavahel, siis tehke teisele Cloud masinale üks-ühele konfiguratsioon, vahetades ainult "Local" ja "Remote" endpoint väljad.

 

5.

Detailsed ingliskeelsed juhendid VMware kodulehelt leiate siit.

 

Aadress: Endla 16, Tallinn 10142Telefon: (+372) 685 0000@email