vCloud IPSec

 

0.

IPSec VPN

 Kui soovid vCloud serveritele ja võrgule ligipääsu võimaldada ainult enda kodust või kontorist ja sulgeda selle ülejäänud maailmale, sobib selleks ideaalselt IPSec VPN lahendus. See tähendab, et võrguliiklus sinu kontori ja vCloudi vahel käib üle turvalisse, krüpteeritud tunneli.

VPN abil võib näiteks ka ühendada kaks geograafiliselt eri punktis asuvat võrku ühtseks tervikuks. IPSec äppid on olemas ka Android ja iOS seadmetele. ipsecScheeme.PNG

Kui soovid luua üksikute kasutajate  arvuti ja vCloud ressursside vahel VPN ühendust loe lähemalt SSL-VPN Plus kohta siit.

 

1.

Ava    vCloud admin console ja mine    Network Edge Gateway sätete alla  (CONFIGURE SERVICES).

 

Edge.PNG

 

  • Mine  VPN aknale ja vali  sealt IPsec VPN Sites

 

 

2.

Create new IPSec tunnel

 

  • Enable IPSec
  • Enable PFS
  • Name → IPSec tunneli nimi
  • Local ID → Edge Gateway avalik IP-aadress
  • Local Endpoint → Edge Gateway avalik IP-aadress
  • Local Subnets → sisemine NAT võrk
  • Peer Id → välisvõrgu avalik IP-aadress
  • Peer Endpoint → välisvõrgu avalik IP-aadress
  • Peer Subnets → välimine NAT võrk
  • Encryption Algorithm → Crypto algoritm
  • Authentication → PSK
  • Pre-Shared Key → tunneli parool, kui välja lülitatud, siis aktiveerida Change Shared Key checkbox
  • Diffie-Hellman Group → DH group

 

VPN1.PNG VPN2.PNG

 

3.

Save and apply all changes

Kui kõik on korrektsealt seadistatud,  lisab  Edge gateway ise kõik vajalikud tulemüüri reeglid ja paneb tunneli püsti.

 

4.

 

Kui kasutad    Edge Gateway'd koos kontori Mikrotikiga. Tee lahti Mikrotiki    console  ja sisesta    järgmised käsud koos parandustega.

  • /ip ipsec proposal add name=VPN_Cloud auth-algorithms=sha1 enc-algorithms=3des lifetime=1h pfs-group=none
  • /ip ipsec policy add dst-address=192.168.2.0/24 proposal=VPN_Cloud sa-dst-address=8.79.116.14 sa-src-address=2.65.41.2 src-address=192.168.3.0/24 tunnel=yes protocol=255 action=encrypt level=require ipsec-protocols=esp
  • /ip ipsec peer add address=8.79.116.14/32 port=500 enc-algorithm=3des lifetime=8h nat-traversal=yes secret=#YourPassword# passive=no exchange-mode=main send-initial-contact=yes proposal-check=obey hash-algorithm=sha1 dh-group=modp1024 generate-policy=no dpd-interval=120 dpd-maximum-failures=5
  • /ip firewall filter add chain=forward dst-address=192.168.3.0/24 src-address=192.168.2.0/24
  • /ip firewall filter add chain=forward dst-address=192.168.2.0/24 src-address=192.168.3.0/24
  • /ip firewall nat add chain=srcnat dst-address=192.168.3.0/24 src-address=192.168.2.0/24
  • /ip firewall nat add chain=srcnat dst-address=192.168.2.0/24 src-address=192.168.3.0/24
  • /ip ipsec export

 

5

Detailsed ingliskeelsed juhendid VMware kodulehelt leiad  siit. 

 

Aadress: Endla 16, Tallinn 10142Telefon: (+372) 685 0000@email